SoC Opel / PSA wird nicht abgerufen

Alles rund um SoC (Ladezustand des Fahrzeuges). Probleme, Fragen, Fehlfunktionen gehören hier hin
Bernd_M
Beiträge: 14
Registriert: Di Sep 27, 2022 12:34 pm

Re: SoC Opel / PSA wird nicht abgerufen

Beitrag von Bernd_M »

MadMurdock hat geschrieben: Sa Sep 30, 2023 5:07 pm Hallo zusammen,

ich betreibe immer noch die OpenWB in Version 1.9.303.0.
Bis vor etwa 2 Monaten funktionierte der SoC Abruf von den PSA Servern. Von heute auf morgen nicht mehr.

LOG Auszug:

Code: Alles auswählen

2023-09-30 19:01:45: PID: 6280: Lp1: Nothing to do yet. Incrementing timer. 5 min online interval wait: 1 (LV1) at 132 main modules/soc_psa/main.sh
2023-09-30 19:01:35: PID: 4944: Lp1: Nothing to do yet. Incrementing timer. 5 min online interval wait: 0 (LV1) at 132 main modules/soc_psa/main.sh
2023-09-30 19:01:28: PID: 3595: Lp1: Fetching SoC from Opel failed (LV0) at 165 main modules/soc_psa/main.sh
2023-09-30 19:01:25: PID: 3595: Lp1: Fetching SoC from Opel (LV0) at 135 main modules/soc_psa/main.sh
2023-09-30 19:01:15: PID: 2252: Lp1: Nothing to do yet. Incrementing timer. 5 min online interval wait: 28 (LV1) at 132 main modules/soc_psa/main.sh
2023-09-30 19:01:05: PID: 885: Lp1: Nothing to do yet. Incrementing timer. 5 min online interval wait: 27 (LV1) at 132 main modules/soc_psa/main.sh
2023-09-30 19:00:55: PID: 31943: Lp1: Nothing to do yet. Incrementing timer. 5 min online interval wait: 26 (LV1) at 132 main modules/soc_psa/main.sh
Das ganze wiederholt sich immer wieder.
Die Daten sind korrekt eingetragen und sogar die APP funktioniert (meistens..)

Hat jmd eine Idee? Habe ich Infos vergessen?

Viele Grüße
Hallo,

seit ein paar Tagen habe ich das Problem bei meinem Corsa, dass der SoC zwar korrekt ausgelesen wird, das Laden allerdings nicht bei dem eingestellten maximalen SoC stoppt. Die Batterie wird immer auf 100% aufgeladen. Eingestellt sind aber 80%. Das hat auch immer funktioniert, nur jetzt eben nicht mehr. Client-ID und Client-Secret im PSA-Modul sind korrekt eingetragen.
Meine Fragen:
1. Weiß jemand, woran das liegen könnte?
2. Wie komme ich an die Log-Dateien ran, die hier gepostet wurden?

Danke und viele Grüße,
Bernd
cstueckrath
Beiträge: 8
Registriert: Do Nov 11, 2021 7:47 am

Re: SoC Opel / PSA wird nicht abgerufen

Beitrag von cstueckrath »

Bei mir geht es mit dem Abruf auch nicht mehr - ich bringe das aber in Zusammenhang mit einer Einrichtung von EEVEE. Das habe ich gemacht, damit der PSA-Car-Controller die Kartendaten abrufen kann.
Bei der EEVEE-Einrichtung wird offenbar eine Art B2B-Schnittstelle des Fahrzeugs oder der API aktiviert, die dann auch die GPS-Daten enthält (bringt für die App selbst leider nichts).

Vielleicht hilft das bei der Problemermittlung.
Benutzeravatar
mrinas
Beiträge: 1796
Registriert: Mi Jan 29, 2020 10:12 pm

Re: SoC Opel / PSA wird nicht abgerufen

Beitrag von mrinas »

Das Tronity Modul unterstützt im aktuellen Master (=nightly) des 2er release die manuelle Berechnung. Das sollte allen mit PSA Modellen helfen, ich hab' auch eben den Ladepunkt in der Garage fürs Auto der Frau auf das 2er Release gehoben.

ah moment, das Feature ist schon drin, der Knopf in der UI fehlt noch. Kommt bestimmt auch gleich..
15,2kWp SMA (SB4000TL-21, SB3.0, STP6.0-SE + BYD HVS, EnergyMeter), openWB Standard+, openWB Pro, Peugeot e2008, Tesla Model Y LR.
cstueckrath
Beiträge: 8
Registriert: Do Nov 11, 2021 7:47 am

Re: SoC Opel / PSA wird nicht abgerufen

Beitrag von cstueckrath »

wobei es aktuell vermutlich seit zwei Wochen generell defekt ist, siehe
https://github.com/flobz/psa_car_controller/issues/733
https://github.com/Stellantis/stellanti ... issues/128
LenaK
Beiträge: 920
Registriert: Fr Jan 22, 2021 6:40 am

Re: SoC Opel / PSA wird nicht abgerufen

Beitrag von LenaK »

mrinas hat geschrieben: Fr Feb 02, 2024 1:29 pm Das Tronity Modul unterstützt im aktuellen Master (=nightly) des 2er release die manuelle Berechnung. Das sollte allen mit PSA Modellen helfen, ich hab' auch eben den Ladepunkt in der Garage fürs Auto der Frau auf das 2er Release gehoben.

ah moment, das Feature ist schon drin, der Knopf in der UI fehlt noch. Kommt bestimmt auch gleich..
Das ist auch schon gemergt. Hast Du die Seite neu geladen?
Benutzeravatar
mrinas
Beiträge: 1796
Registriert: Mi Jan 29, 2020 10:12 pm

Re: SoC Opel / PSA wird nicht abgerufen

Beitrag von mrinas »

LenaK hat geschrieben: Fr Feb 02, 2024 2:33 pm
mrinas hat geschrieben: Fr Feb 02, 2024 1:29 pm Das Tronity Modul unterstützt im aktuellen Master (=nightly) des 2er release die manuelle Berechnung. Das sollte allen mit PSA Modellen helfen, ich hab' auch eben den Ladepunkt in der Garage fürs Auto der Frau auf das 2er Release gehoben.

ah moment, das Feature ist schon drin, der Knopf in der UI fehlt noch. Kommt bestimmt auch gleich..
Das ist auch schon gemergt. Hast Du die Seite neu geladen?
joa stimmt, da isser, der Haken den ich gebaut habe. Entweder hab' ich den übersehen oder es war tatsächlich ein Refresh-problem (wenngleich das ja eigentlich nicht mehr existieren sollte). Anyway, der Button ist da.
15,2kWp SMA (SB4000TL-21, SB3.0, STP6.0-SE + BYD HVS, EnergyMeter), openWB Standard+, openWB Pro, Peugeot e2008, Tesla Model Y LR.
Antworten