Support: Hyundai

Alles rund um SoC (Ladezustand des Fahrzeuges). Probleme, Fragen, Fehlfunktionen gehören hier hin
Flocki
Beiträge: 456
Registriert: Fr Aug 28, 2020 12:43 pm

Re: Support: Hyundai

Beitrag von Flocki »

Die Logindaten werden nicht zwischen Modulen übernommen, bitte alle nochmal neu eintippen und abspeichern.
LinusEV
Beiträge: 95
Registriert: Do Dez 26, 2019 4:00 pm

Re: Support: Hyundai

Beitrag von LinusEV »

Jetzt ist LP1 verschwunden in der Abfrage
2021-05-27 21:39:34: Lp2: Nothing to do yet. Incrementing timer. (LV0)
2021-05-27 21:39:24: Lp2: Nothing to do yet. Incrementing timer. (LV0)
2021-05-27 21:39:14: Lp2: Nothing to do yet. Incrementing timer. (LV0)
2021-05-27 21:39:13: LP1: Login failed
2021-05-27 21:39:12: LP1: SoC download starting


sah vorher so aus:
2021-05-27 21:31:57: Lp1: Nothing to do yet. Incrementing timer. (LV0)
2021-05-27 21:31:54: Lp2: Nothing to do yet. Incrementing timer. (LV0)
2021-05-27 21:31:47: Lp1: Nothing to do yet. Incrementing timer. (LV0)
2021-05-27 21:31:44: Lp2: Nothing to do yet. Incrementing timer. (LV0)
Flocki
Beiträge: 456
Registriert: Fr Aug 28, 2020 12:43 pm

Re: Support: Hyundai

Beitrag von Flocki »

Stall mal unter Einstellungen->System->Debugging den Modus auf 2. Dann sollte das Modul etwas gesprächiger werden, was im Hintergrund passiert.
LinusEV
Beiträge: 95
Registriert: Do Dez 26, 2019 4:00 pm

Re: Support: Hyundai

Beitrag von LinusEV »

Ok, Danke für den Hinweis
Hier hat die 15 min Grenze zugeschlagen
021-05-27 22:00:29: LP1: Kia/Hyundai SoC Module ending
2021-05-27 22:00:29: LP1: Nothing to do yet
2021-05-27 22:00:29: LP1: Last Download less then 15 minutes ago. Cancelling download
2021-05-27 22:00:29: LP1: SoC download triggered by timer
2021-05-27 22:00:29: LP1: Kia/Hyundai SoC Module starting
LinusEV
Beiträge: 95
Registriert: Do Dez 26, 2019 4:00 pm

Re: Support: Hyundai

Beitrag von LinusEV »

Jo, wenn man 15 min wartet, geht es nun bei mir auch!
Besten Dank
gorthon
Beiträge: 218
Registriert: So Okt 04, 2020 4:33 pm

Re: Support: Hyundai

Beitrag von gorthon »

Habe gestern auf die aktuelle nightly upgedatet und erhalte nun zum ersten Mal von diesem Modul falsche Werte (früher gab es entweder keinen Wert oder den korrekten):

Code: Alles auswählen

2021-05-29 11:51:21: LP1: Received SoC (HV-battery): 48%
2021-05-29 11:51:19: LP1: SoC download starting
2021-05-29 11:23:24: LP1: Received SoC (HV-battery): 96%
2021-05-29 11:22:08: LP1: SoC download starting
2021-05-29 10:51:01: LP1: Received SoC (HV-battery): 48%
2021-05-29 10:50:58: LP1: SoC download starting
2021-05-29 09:55:38: LP1: Received SoC (HV-battery): 87%
2021-05-29 09:54:28: LP1: SoC download starting
2021-05-28 20:40:35: LP1: Received SoC (HV-battery): 75%
2021-05-28 20:40:18: LP1: SoC download starting
2021-05-28 16:42:34: LP1: Received SoC (HV-battery): 73%
2021-05-28 16:41:23: LP1: SoC download starting
Wagen war die ganze Zeit angestöpselt und Ladung ging von 73% auf 94% hoch (die automatische Zwischenberechnung wird im Log leider nicht mehr angezeigt). Habe dann die 70%-Regelung aktiviert, worauf das Laden gedrosselt und zeitweise gestoppt wurde. Plötzlich sehe ich 48% in der Anzeige. Manuelle Abfrage über openWB gestartet: 96%. Später wieder geguckt: Wieder 48%. Sehr seltsam, zumal es genau die Hälfte von 96 ist.

Abfrageintervall ist auf 240 Minuten gestellt, das scheint aber nicht richtig berücksichtigt zu werden, denn warum fragt er sonst nach 9:55 schon wieder um 10:50 ab und dann wieder um 11:51? (Das um 11:22 war meine manuelle Abfrage).
gorthon
Beiträge: 218
Registriert: So Okt 04, 2020 4:33 pm

Re: Support: Hyundai

Beitrag von gorthon »

Ein bisschen abgewartet und jetzt zeigt er wieder 98%:

Code: Alles auswählen

2021-05-29 12:16:28: LP1: Received SoC (HV-battery): 98%
2021-05-29 12:15:15: LP1: SoC download starting
2021-05-29 12:14:15: LP1: Received SoC (HV-battery): 0%
2021-05-29 12:13:58: LP1: SoC download starting
2021-05-29 11:51:21: LP1: Received SoC (HV-battery): 48%
2021-05-29 11:51:19: LP1: SoC download starting
Sehr seltsam. Und wieso fragt er so häufig ab, ich habe ja das Intervall extra auf 4 Stunden gesetzt, damit mir die 12V-Batterie nicht wieder leer geht.
Flocki
Beiträge: 456
Registriert: Fr Aug 28, 2020 12:43 pm

Re: Support: Hyundai

Beitrag von Flocki »

Das leider ein Bug auf den Servern. Aus unerfindlichen Gründen schickt der immer wieder mal nicht den letzten bekannten, sondern einen alten Wert (meistens ist der 2-3 Tage alt), aber mit aktuellem Datum. (Passiert auch in der App... Wenn du die gleichzeitig aufgemacht hättest, wären da wahrscheinlich auch die 48% gestanden)

Wenn du die Details von der automatischen Berechnung sehen willst, musst du den Debugging level höher stellen unter Einstellungen->System->Debugging.

Die Abrufe werden nicht nur in dem angegebenen Interval durchgeführt, sondern auch beim Anstecken des Autos und bei Ladebeginn (und das kann vor allem im PV-Modus deutlich häufiger sein, wenn Wolken durchzeihen und die Ladung unterbrechen).
gorthon
Beiträge: 218
Registriert: So Okt 04, 2020 4:33 pm

Re: Support: Hyundai

Beitrag von gorthon »

Flocki hat geschrieben: Sa Mai 29, 2021 11:44 am Das leider ein Bug auf den Servern. Aus unerfindlichen Gründen schickt der immer wieder mal nicht den letzten bekannten, sondern einen alten Wert (meistens ist der 2-3 Tage alt), aber mit aktuellem Datum. (Passiert auch in der App... Wenn du die gleichzeitig aufgemacht hättest, wären da wahrscheinlich auch die 48% gestanden)
Das hatte ich in der App auch schonmal erlebt, allerdings war der Wert dann 0%. Einen falschen Wert anders als 0 hatte ich bisher noch nicht, werde aber mal mehr darauf achten.

Flocki hat geschrieben: Sa Mai 29, 2021 11:44 am Wenn du die Details von der automatischen Berechnung sehen willst, musst du den Debugging level höher stellen unter Einstellungen->System->Debugging.
Das lässt sich leider nicht länger durchhalten, weil dann so viele Einträge kommen (alle paar Sekunden "Hyundai module started" ...), dass man es schnell wieder ausmacht :-) Fand es besser, als die automatische Berechnung auch im normalen Log war, weil man dann, wenn ein paar Stunden später wieder der Wert vom Auto abgerufen wurde, schön sehen konnte, wie gut die automatische Berechnung war. Habe damit ein gutes Finetuning durchgeführt.

Flocki hat geschrieben: Sa Mai 29, 2021 11:44 am Die Abrufe werden nicht nur in dem angegebenen Interval durchgeführt, sondern auch beim Anstecken des Autos und bei Ladebeginn (und das kann vor allem im PV-Modus deutlich häufiger sein, wenn Wolken durchzeihen und die Ladung unterbrechen).
Mir war nicht bewusst, dass das noch immer so ist. Das führt das Einstellen eines langen Intervalls ja ad absurdum, wenn dann bei durchziehenden Wolken doch viel häufiger abgefragt wird. Vor allem, wozu? Wenn das Auto zwischendurch nicht abgesteckt war, wird sich der SoC wohl kaum verändert haben. Könnte man unterbinden, dass das Auto angefragt wird, wenn das Abfrageintervall noch nicht erreicht ist?
gorthon
Beiträge: 218
Registriert: So Okt 04, 2020 4:33 pm

Re: Support: Hyundai

Beitrag von gorthon »

P.S.: Der Server-Bug mit den alten Werten muss in der Form neu sein, hatte ich so krass noch nie. Ließe sich das verhindern durch

Code: Alles auswählen

IF ( [vom Server gemeldeter Wert] < [vorheriger Wert vom Server - 1%punkt] )  
 	AND [Fahrzeug zwischendurch nicht abgesteckt]
THEN
	keep current value
Gesperrt