Support: Tesla

Alles rund um SoC (Ladezustand des Fahrzeuges). Probleme, Fragen, Fehlfunktionen gehören hier hin
Nickbig
Beiträge: 54
Registriert: So Mai 02, 2021 2:02 pm

Re: Support: Tesla

Beitrag von Nickbig »

Läuft die SOC-Abfrage mittlerweile wieder stabil?
Gero
Beiträge: 2242
Registriert: Sa Feb 20, 2021 9:55 am

Re: Support: Tesla

Beitrag von Gero »

Bei mir schon. 1.9 aktuellea Nightly
openWB-series2, openWB-Buchse, E3/DC S10pro+19.5kWh, 30kWp Ost-Süd, Model 3 und Ion
Nickbig
Beiträge: 54
Registriert: So Mai 02, 2021 2:02 pm

Re: Support: Tesla

Beitrag von Nickbig »

Leider ist das Problem mit der SoC Abfrage auch mit der Nightly 1.9.304.0 vorhanden.
Nach der Ersteinrichtung funktioniert es. Nach einiger Zeit gibt es dann wieder einen Token Refresh Error.

Umgebung:
Raśpberry Pi 3b
NRG Kick
Solar Edge
Tesla Model 3 11/2020
LutzB
Beiträge: 3375
Registriert: Di Feb 25, 2020 9:23 am

Re: Support: Tesla

Beitrag von LutzB »

Nickbig hat geschrieben: So Okt 29, 2023 7:17 pm Leider ist das Problem mit der SoC Abfrage auch mit der Nightly 1.9.304.0 vorhanden.
Nach der Ersteinrichtung funktioniert es. Nach einiger Zeit gibt es dann wieder einen Token Refresh Error.

Umgebung:
Raśpberry Pi 3b
NRG Kick
Solar Edge
Tesla Model 3 11/2020
Wenn Du ein paar beiträge zurück nachsiehst, wirst Du feststellen, dass keine konkrete Ursache für das Verhalten bei einigen Installationen gefunden werden konnte. Wie soll etwas geändert werden, wenn keine Ursache ausgemacht werden kann?

Der Hinweis auf die jetzt offizielle API für Drittanbieter ist super. Bis ich das umsetzen kann, wird es aber noch einige Zeit brauchen. Wenn sich jemand daran versuchen möchte, gerne einen PR stellen. Vielleicht gibt es bei der API weniger bis keine Probleme bei der Abfrage.
Gero
Beiträge: 2242
Registriert: Sa Feb 20, 2021 9:55 am

Re: Support: Tesla

Beitrag von Gero »

LutzB hat geschrieben: Mo Okt 30, 2023 6:40 am die jetzt offizielle API für Drittanbieter
...hat leider auch den Nachteil, dass man sich bei Tesla als Entwickler registrieren muss, weil man diese ID bei den Requests mitgeben muss. Und dann ist aktuell wohl alles noch kostenlos, das muss aber nicht so bleiben.

Mit github und python kenne ich mich so gar nicht aus, kann aber mal versuchen ein paar curls zusammenzustellen. Die sind dann sicherlich relativ einfach in python zu übersetzen, denke ich mal. Ich kuck' mal, ob ich aus dem ganzen Kram schlau werde.
openWB-series2, openWB-Buchse, E3/DC S10pro+19.5kWh, 30kWp Ost-Süd, Model 3 und Ion
Benutzeravatar
mrinas
Beiträge: 1796
Registriert: Mi Jan 29, 2020 10:12 pm

Re: Support: Tesla

Beitrag von mrinas »

Gero hat geschrieben: Mo Okt 30, 2023 9:11 am
LutzB hat geschrieben: Mo Okt 30, 2023 6:40 am die jetzt offizielle API für Drittanbieter
...hat leider auch den Nachteil, dass man sich bei Tesla als Entwickler registrieren muss, weil man diese ID bei den Requests mitgeben muss. Und dann ist aktuell wohl alles noch kostenlos, das muss aber nicht so bleiben.

Mit github und python kenne ich mich so gar nicht aus, kann aber mal versuchen ein paar curls zusammenzustellen. Die sind dann sicherlich relativ einfach in python zu übersetzen, denke ich mal. Ich kuck' mal, ob ich aus dem ganzen Kram schlau werde.
Ich hatte mir das auch schon mal angeschaut, ich könnte mir gut vorstellen dass die Registrierung als Developer einmalig zentral vorgenommen wird und danach jeder Anwender nur mehr die Authorisierung der App gegen seinen Account vornehmen muss. Im Grunde so wie ich das bei OneDrive ja auch gemacht habe.
15,2kWp SMA (SB4000TL-21, SB3.0, STP6.0-SE + BYD HVS, EnergyMeter), openWB Standard+, openWB Pro, Peugeot e2008, Tesla Model Y LR.
Gero
Beiträge: 2242
Registriert: Sa Feb 20, 2021 9:55 am

Re: Support: Tesla

Beitrag von Gero »

Ich hab' mal auf den Registrierungs-Link geklickt. Man wird nach Firmen-Name, USt-Id und Adresse gefragt und muss einen App-Namen angeben zusammen mit einer kurzen Beschreibung, was die App tun soll. Im nächsten Schritt müssen Allowed Origin-, Redirect- und Return-URLs angegeben werden, die gewhithelistet werden. Da bin ich dann raus, dafür müsste ich ja einen webserver betreiben. Auf dem müssen übrigens auch in der .well_known-section die im nächsten Schritt vermutlich generierten Keys gepackt werden.

Ich würde sagen, das muss openWB machen. Eine Schwierigkeit wird vielleicht der open source Charakter sein, falls da private Schlüssel im source-Code drin sein müssen schließt das ja eigentlich die API-Nutzung aus. Aber das muss man dann mal sehen, würde ich sagen. In den Terms of Service https://www.tesla.com/legal/terms#fleet-api-agreement wird wenig überraschend ja die Weitergabe von privaten Schlüsseln untersagt. Ein bisschen doof ist die darauf folgende Einschränkung, dass man die API nicht für nicht dem Lizenznehmer gehörende Autos nutzen darf:

[quote]4.5.4. Provide API access for any vehicle that is not a Licensee Vehicle.[/quote]

Das würde zur Fleet-API passen, denn dem Flottenbetreiber gehören ja üblicherweise auch die Autos. Wenn der Lizenznehmer allerdings jemand ist, der die Software für Flottenbetreiber bereitstellt, dann passt das nicht mehr.

Ist dann irgendwie doch nicht sooo einfach. :-(
openWB-series2, openWB-Buchse, E3/DC S10pro+19.5kWh, 30kWp Ost-Süd, Model 3 und Ion
Benutzeravatar
mrinas
Beiträge: 1796
Registriert: Mi Jan 29, 2020 10:12 pm

Re: Support: Tesla

Beitrag von mrinas »

Hm, das mit den private Keys muss nicht unbedingt ein Problem sein. Die würde man in der Tat nicht weitergeben, ggf. sind die auf dem Client gar nicht notwendig. Aber mag natürlich gut sein dass ein onprem deployment nicht mit auf dem Schirm hatten sondern von einer Client/Server Anwendung ausgehen. Hier bleiben die Schlüssel unter Verschluss auf dem Server.
15,2kWp SMA (SB4000TL-21, SB3.0, STP6.0-SE + BYD HVS, EnergyMeter), openWB Standard+, openWB Pro, Peugeot e2008, Tesla Model Y LR.
Nickbig
Beiträge: 54
Registriert: So Mai 02, 2021 2:02 pm

Re: Support: Tesla

Beitrag von Nickbig »

LutzB hat geschrieben: Mo Okt 30, 2023 6:40 am Wenn Du ein paar beiträge zurück nachsiehst, wirst Du feststellen, dass keine konkrete Ursache für das Verhalten bei einigen Installationen gefunden werden konnte. Wie soll etwas geändert werden, wenn keine Ursache ausgemacht werden kann?
Das verwunderliche aus meiner Sicht ist, dass der Tesla-SoC aktualisiert wird, wenn man in OpenWB in die Modulkonfiguration geht und dort (ohne irgendeinen Wert zu verändern) nur auf „speichern“ klickt. Danach wird der SoC aktualisiert - ohne Token-Fehler

Scheinbar läuft dann beim „Speichern“ in der Modulkonfiguration eine andere Routine ab, als beim normalen SoC-Aktualisieren während des Ladevorvorgangs. Dies Verhalten zeigt mir, dass OpenWB auch grundsätzlich weiterhin den SoC aktualisieren kann/könnte …
LutzB
Beiträge: 3375
Registriert: Di Feb 25, 2020 9:23 am

Re: Support: Tesla

Beitrag von LutzB »

Das funktioniert ja auch bei mir und vielen anderen zuverlässig. ;) Warum das nicht überall so ist, gilt es noch zu klären. Aktuell gibt es keinen Anhaltspunkt dazu.
Antworten