Support: Manuell + Berechnung

Alles rund um SoC (Ladezustand des Fahrzeuges). Probleme, Fragen, Fehlfunktionen gehören hier hin
Philip
Beiträge: 73
Registriert: Fr Okt 27, 2023 6:41 am

Re: Support: Manuell + Berechnung

Beitrag von Philip »

Hallo Community!

Habe eine neue OpenWB Series 2 Standard+, neu eingerichtet (SW V2, aktuelle SW, neu gestartet, virtueller Zähler, interner Ladepunkt). Mein Auto ist ein Fiat500e und ich hätte gerne das SoC-Modul "Manuell" genutzt.

Nun erstelle ich ein Fahrzeug und wähle das entsprechende SoC-Modul aus. Speichere und aktualisiere die Seite. Und dann ist das Modul jedesmal wieder deaktiviert. Wenn ich vorher ein Fahrzeug-Profil / Lade-Profil konfiguriere, passiert das gleiche.

Hab ich irgendwas nicht beachtet?

Danke Euch!
LenaK
Beiträge: 920
Registriert: Fr Jan 22, 2021 6:40 am

Re: Support: Manuell + Berechnung

Beitrag von LenaK »

Bitte eine Sicherung ersetellen und dann mit der aktuellen Beta nochmal testen.
Philip
Beiträge: 73
Registriert: Fr Okt 27, 2023 6:41 am

Re: Support: Manuell + Berechnung

Beitrag von Philip »

Lena, funktioniert! Zumindest bleibt das SoC-Modul jetzt gespeichert. Und "Colors" sieht geil aus 8-)

Bin begeistert!
Saxndi
Beiträge: 4
Registriert: Mi Nov 15, 2023 3:57 pm

Re: Support: Manuell + Berechnung

Beitrag von Saxndi »

Hallo zusammen,

Habe eine OpenWB Series 2 Standard+ und letzte Woche auf Software 2.0 geupdatet. Daran hängt u.a. ein VW eUp, der das SoC-Modul "Manuell" nutzt.

Die Hochrechnung des aktuellen Ladestands funktioniert einwandfrei und die Anzeige in Software 2.0 ist auch viel schöner.
Allerdings zeigt die openwb im SOC-Modul jetzt immer auch die (aktuelle) Reichweite des Fahrzeugs an. Bei mir wird hier aber immer 0 km angezeigt.

Könnte man die Reichweite nicht anhand der im Fahrzeugprofil gespeicherten Daten (Batteriekapazität, Verbrauch) und dem aktuellen Ladestand berechnen, bzw. abschätzen? Das wäre schön.
Oder funktioniert es bei mir einfach nicht richtig und die Hochrechnung ist bereits implementiert?

Viele Grüße
Dateianhänge
Screenshot 2023-11-15 170103.png
Screenshot 2023-11-15 170103.png (10.86 KiB) 946 mal betrachtet
zut
Beiträge: 356
Registriert: Di Feb 23, 2021 9:34 pm

Re: Support: Manuell + Berechnung

Beitrag von zut »

Das sollte besser im Parallelthread für das Thema "colors" besprochen werden, da das separat entwickelt wird.
LenaK
Beiträge: 920
Registriert: Fr Jan 22, 2021 6:40 am

Re: Support: Manuell + Berechnung

Beitrag von LenaK »

Das ist hier schon der richtige Thread dafür, da solche Werte nicht im Theme berechnet werden. Die Werte kommen aus dem Backend und werden vom Theme nur angezeigt.
Aktuell ist die Reichweiten-Berechnung für das Manuelle SoC nicht implementiert.
_Michael_
Beiträge: 3
Registriert: Do Apr 06, 2023 2:47 pm

Re: Support: Manuell + Berechnung

Beitrag von _Michael_ »

Hallo zusammen,

bei mir werden im Theme seit etwa einem Monat die SoC-Werte beim Anstecken des Berlingo nicht mehr aktualisiert:

- Lade z. b. auf 80,57%.
- Anstecken nach der Fahrt, echter SoC 40% (laut Anzeige und App vom Berlingo und laut connect.php von der Wallbox).
- Theme zeigt 80,57% (den errechneten Endwert des letzten Ladevorgangs) an und rechnet dann beim Laden hoch.
- Irgendwann wird dann nicht mehr geladen, da Ziel-SoC erreicht (obwohl der echte SoC viel niedriger ist).

Habe das erst im PSA-Modul bemerkt (das Modul hatte seit 8 Monaten eigentlich gut funktioniert), dann auf das Manuell-Modul gewechselt. Im Manuell-Modus kann ich nun den SoC-Wert per Hand eintragen und damit die Ladung wieder ermöglichen.

Software ist der aktuelle Master; gleiches Verhalten bei Beta und Release (da gibt es die Option "Soc aus Fahrzeug auslesen" noch nicht, aber bei Master und Beta funktioniert es bei mir trotz aktivierter Option genauso wenig). WB Pro Charging Stack Version 3.2.0
Dateianhänge
ConnectPHP.jpg
SoC-CTheme.jpg
Konfiguration-Fahrzeug.jpg
------------------------------------------------------------------------------------------------------------------------------
openWB Pro über openWB Standalone mit software2, openWB EVU Kit v2 MID; 19,2 kWp Hyundai, Kostal Pico; e-Berlingo, Tesla Y LR
LenaK
Beiträge: 920
Registriert: Fr Jan 22, 2021 6:40 am

Re: Support: Manuell + Berechnung

Beitrag von LenaK »

Bei Release und Beta funktioniert das Auslesen aus dem Fahrzeug nicht, dh da musst du das PSA-Modul konfigurieren.
Es gab gestern noch einen Fix für das Auslesen aus dem Fahrzeug. Bitte auf den aktuellen Master updaten und auch die Pro auf Version 3.2.1 updaten.
_Michael_
Beiträge: 3
Registriert: Do Apr 06, 2023 2:47 pm

Re: Support: Manuell + Berechnung

Beitrag von _Michael_ »

Habe die Pro auf 3.2.1 und danach das Backend auf den aktuellen Master (Version 17.11.23, 9:21 Uhr) geupdatet.
SoC aus connect.php wird weiterhin nicht ins Theme/Backend übernommen.
------------------------------------------------------------------------------------------------------------------------------
openWB Pro über openWB Standalone mit software2, openWB EVU Kit v2 MID; 19,2 kWp Hyundai, Kostal Pico; e-Berlingo, Tesla Y LR
_Michael_
Beiträge: 3
Registriert: Do Apr 06, 2023 2:47 pm

Re: Support: Manuell + Berechnung

Beitrag von _Michael_ »

Habe den Berlingo aus der Konfiguration gelöscht und das Backend auf den aktuellen Master (Version 17.11.23, 18:03 Uhr) geupdatet.
Danach den Berlingo neu in der Konfiguration angelegt und angesteckt.
SoC aus connect.php wird nun in Theme/Backend übernommen.
Zusätzlich wird beim colors-Theme im Manuell-SoC-Modul die Reichweite wie erwartet nicht mehr angezeigt. Vermute daher, dass beim Wechsel zwischen dem PSA-Modul und dem Manuell-Modul etwas schiefgelaufen war, was durch die Neuanlage des Fahrzeugs behoben worden ist.
Oder es war eine Änderung im Master-Update :?:
------------------------------------------------------------------------------------------------------------------------------
openWB Pro über openWB Standalone mit software2, openWB EVU Kit v2 MID; 19,2 kWp Hyundai, Kostal Pico; e-Berlingo, Tesla Y LR
Antworten