Rückmeldungen openWB software 2.1.4 Alpha 1

Fragen zur Nutzung, Features, usw..
Jens
Beiträge: 103
Registriert: Fr Jul 16, 2021 6:19 pm

Re: Rückmeldungen openWB software 2.1.4 Alpha 1

Beitrag von Jens »

Nasdero hat geschrieben: Mi Mär 27, 2024 8:53 am Restreichweite bei Manueller SoC im Status wird nicht berechnet.

(2024-03-26 14:19:18 +0100 [d61253c4a])

Beim ZOE ist er da, da ist kein manueller SoC an.
LenaK hat geschrieben: Mo Mär 25, 2024 9:21 am
Elchkopp hat geschrieben: Mo Mär 25, 2024 8:15 am @LenaK und @LutzB:

Im Colors-Theme ist electron aufgefallen, dass das SoC-Modul "Manueller SoC" scheinbar einen Fehler hat: das Topic /chargepoint/<x>/get/connected_vehicle/soc/range
iefert als Wert für die Reichweite "null" anstatt "0":

Code: Alles auswählen

{"fault_str": "Kein Fehler.", "fault_state": 0, "range_charged": 29.01111111111111, "range_unit": "km", "range": null, "soc": 60.2, "timestamp": 1711207873.376526}
Ebenso die Alternative
/vehicle/<x>/get/range

Im SoC-Log sind keine Fehler für mich zu erkennen:

Code: Alles auswählen

2024-03-23 18:19:39,918 - {modules.common.configurable_vehicle:56} - {DEBUG:fetch soc_ev2} - Vehicle Instance <class 'modules.vehicles.manual.config.ManualSoc'>
2024-03-23 18:19:39,922 - {modules.common.configurable_vehicle:57} - {DEBUG:fetch soc_ev2} - Calculated SoC-State CalculatedSocState(imported_start=1490935, manual_soc=61, soc_start=50)
2024-03-23 18:19:39,923 - {modules.common.configurable_vehicle:58} - {DEBUG:fetch soc_ev2} - Vehicle Update Data VehicleUpdateData(plug_state=False, charge_state=False, imported=None, battery_capacity=58000, efficiency=98, soc_from_cp=None, timestamp_soc_from_cp=None)
2024-03-23 18:19:39,924 - {modules.common.configurable_vehicle:59} - {DEBUG:fetch soc_ev2} - General Config GeneralVehicleConfig(use_soc_from_cp=True, request_interval_charging=300, request_interval_not_charging=43200, request_only_plugged=True)
2024-03-23 18:19:39,924 - {modules.common.component_context:25} - {DEBUG:fetch soc_ev2} - Update Komponente ['Manueller SoC']
2024-03-23 18:19:39,925 - {modules.common.configurable_vehicle:67} - {DEBUG:fetch soc_ev2} - Requested start soc from manual: 61%
2024-03-23 18:19:39,929 - {modules.common.store._api:26} - {DEBUG:fetch soc_ev2} - Raw data CarState(soc=61, range=None, soc_timestamp=0)
2024-03-23 18:19:39,971 - {modules.common.store._api:30} - {INFO:store soc_ev2} - Saving CarState(soc=61, range=None, soc_timestamp=0)
Auch das testweise Anlegen eines weiteren/neuen Fahrzeuges in der Konfiguration mit Einbeziehung des SoC-Moduls hat das Ergebnis nicht verändert.

Ich bin auf dem aktuellen Release:
2024-03-19 06:56:08 +0100 [a6b648645]

Quelle:
viewtopic.php?p=105577#p105577
Das manuelle SoC-Modul berechnet keine Reichweite. Von daher: Wert 0 bedeutet 0km, None bedeutet keine Reichweite bekannt.
PV: 9,86kWp an E3DC S10 13kWh
LP1: openWB Series2 standard+
Kia EV6
Nutzung von Tibber
hoaloha
Beiträge: 61
Registriert: Di Feb 23, 2021 7:18 pm

Re: Rückmeldungen openWB software 2.1.4 Alpha 1

Beitrag von hoaloha »

ChristophR hat geschrieben: Di Mär 26, 2024 6:46 pm Im Ladeprotokoll März habe ich eine komische Summe, das einzige Auffällige ist, dass beim letzten Ladevorgang keine Reichweite "geladen" wurde:
2024-03-26 19_41_19-openWB _ Auswertungen - Ladeprotokoll und 1 weitere Seite - Persönlich – Microso.png
Ist bei mir auch der Fall.

Version: 2024-03-26 14:19:18 +0100 [d61253c4a]

Zusätzlich bekomme ich keine MQTT Werte mehr. Sowohl im iobroker Client - abgefragte Topics:
topics.jpg
(73.42 KiB) Noch nie heruntergeladen
und auch der MQTT Explorer bleibt stumm:
mqtt_explorer.jpg
(132.7 KiB) Noch nie heruntergeladen
2x openWB series2 standard+ // EVU Modul: E3DC // SOC Modul: Tesla // HA: ioBroker
LutzB
Beiträge: 3494
Registriert: Di Feb 25, 2020 9:23 am

Re: Rückmeldungen openWB software 2.1.4 Alpha 1

Beitrag von LutzB »

Nasdero hat geschrieben: Mi Mär 27, 2024 8:53 am Restreichweite bei Manueller SoC im Status wird nicht berechnet.
Die Reichweite wird auch nicht berechnet, sondern lediglich die geladene Reichweite.
Eine absolute Reichweite gibt es nur, wenn das entsprechende SoC Modul diese Info auch vom Fahrzeug auslesen kann.
LenaK
Beiträge: 1029
Registriert: Fr Jan 22, 2021 6:40 am

Re: Rückmeldungen openWB software 2.1.4 Alpha 1

Beitrag von LenaK »

Ist behoben.
LutzB
Beiträge: 3494
Registriert: Di Feb 25, 2020 9:23 am

Re: Rückmeldungen openWB software 2.1.4 Alpha 1

Beitrag von LutzB »

Ich habe die Beiträge zum Thema MQTT mal verschoben: viewtopic.php?t=8574

Ebenfalls sind die Beiträge zum Ausfall der Preise bei Tibber entfernt worden, da die nichts mit dem Release zu tun haben.
ChristophR
Beiträge: 411
Registriert: So Okt 30, 2022 8:07 am

Re: Rückmeldungen openWB software 2.1.4 Alpha 1

Beitrag von ChristophR »

LenaK hat geschrieben: Mi Mär 27, 2024 12:09 pmIst behoben.
Hallo Lena,

ich gehe mal davon aus, dass Du die Summe im Ladeprotokoll meinst.

Aktueller master (2024-03-27 13:23:59 +0100 [66415494a]):
Die Summen werden nun wieder angezeigt, allerdings führt der NULL Wert bei den fehlerhaften Einträgen dazu, dass die Summe (Geladene km) insgesamt immer 0km ist.
Der Fehler, dass beim Ladevorgang im Protokoll bei der geladenen Reichweite ein NULL Wert geschrieben wird, ist noch vorhanden.
Während des Ladevorganges war noch eine geladene Reichweite auf der Hauptseite zu sehen.
Ich habe mal das chargelog beigefügt, vielleicht hilft Euch das?
chargelog.d20240329-u040003.log.zip
(6.82 KiB) 5-mal heruntergeladen
openWB Series 2 Standard+, SW-Version 2
SolarEdge SE10K-RWS, BYD LVS 8, 16,8 kWp.
CUPRA Born
LenaK
Beiträge: 1029
Registriert: Fr Jan 22, 2021 6:40 am

Re: Rückmeldungen openWB software 2.1.4 Alpha 1

Beitrag von LenaK »

Die geladenen Kilometer werden mit dem aktuellen Master wieder im Ladeprotokoll ausgegeben.
Candid
Beiträge: 84
Registriert: So Mai 03, 2020 3:15 pm

Re: Rückmeldungen openWB software 2.1.3 Release & Release Patch 1

Beitrag von Candid »

Ich habe wieder das Problem, das eigentlich mal behoben war, dass beim Laden bei wenig PV-Leistung der Speicher hinzugezogen wird, aber ständig über die max. erlaubte Entnahme aus dem Speicher gegangen wird. Was dann zu den Schwingungen führt. Ablauf ist, der Ladevorgang beginnt, dann geht die Ladeleistung plötzlich bis deutlich über 6kW aus Speicher + PV-Leistung (die liegt bei Ladebeginn noch um 2 kW und im weiteren Verlauf dann bei < 1kW). Dann erfolgt die Runterregelung, da vom EVU gezogen wird. Und das schwingt dann munter. Ab und an komischerweise ohne die Schwingung, dann wieder mit.

Nach 18:35 Uhr war dann noch die Mikrowelle kurz an und direkt danach ging es mit der Schwingung weiter. Im Screenshot von der Oberfläche sieht man auch gut die Werte. Aus dem Speicher kommen 7,48 kW, von der PV 396 W, Hausverbrauch ist 580 W. Vom EVU kommen 779 W und die openWB lädt gerade mit 9,09 kW. Nach meinem Verständnis sollte die openWB zu keinem Zeitpunkt mit mehr als 6kW + PV laden.
Dateianhänge
20240402 Bildschirmfoto Ladeeinstellungen PV-Laden um 19.33.29.png
(1.27 MiB) Noch nie heruntergeladen
20240402 Bildschirmfoto um 19.01.20.png
(369.13 KiB) Noch nie heruntergeladen
20240402 Logfile Main.txt
(394.18 KiB) 14-mal heruntergeladen
Meine Konfig:
openWB series2 standard+

E3DC S10 E Pro
Zusatzwechselrichter E3DC SWR12PR
Tesla Model 3
MatzeL
Beiträge: 48
Registriert: Mi Mai 17, 2023 6:58 pm

Re: Rückmeldungen openWB software 2.1.3 Release & Release Patch 1

Beitrag von MatzeL »

Candid hat geschrieben: Di Apr 02, 2024 5:25 pm Aus dem Speicher kommen 7,48 kW, von der PV 396 W, Hausverbrauch ist 580 W. Vom EVU kommen 779 W und die openWB lädt gerade mit 9,09 kW. Nach meinem Verständnis sollte die openWB zu keinem Zeitpunkt mit mehr als 6kW + PV laden.
Nur aus der Ansicht des Screenshots sieht es für mich so aus, als würde die Wallbox gerne mit mehr Leistung laden, es wird Strom vom EVU bezogen (mehr als 0,6kW), darauf hin regelt die WB wieder ab.
Der Wert bei Minimum scheint mir mit 200W Bezug recht hoch zu sein.

Aber ob das wirklich hier in den Feedback Thread gehört, wage ich zu bezweifeln.
PV: Fronius Symo Speicher: Victron Auto: Skoda Enyaq mit ME3.6

openWB Pro + openWB Standalone mit Display
heidanei
Beiträge: 77
Registriert: So Mai 02, 2021 5:42 pm

Re: Rückmeldungen openWB software 2.1.4 Alpha 1

Beitrag von heidanei »

Hallo zusammen!

Nachdem die Grundfunktionen inzwischen bei mir recht stabil funktionieren hätte ich ein paar Fragen die eher in die Kategorie "Schöner Wohnen" fallen, aber vielleicht ohne allzu großen Aufwand umsetzbar und vielleicht nicht nur für mich nützlich wären:

1.) Ständige Meldungen betreffend der Phasenumschaltung, obwohl in meiner smartWB gar keine vorhanden ist. (Siehe auch hier: viewtopic.php?t=8536)

2.) Eine Frage hätte ich mal zu den Einstellmöglichkeiten der Lademengenbegrenzung in den verschiedenen Lademodi, die ist ja derzeit nicht konsistent.
Bei Sofortladen habe ich ja diese drei Buttons "keine", "EV-SOC" und "Energiemenge", bei PV-Laden im Prinzip nur nach SOC, das man - endlich - jetzt seit kurzem auch mit dem Max-Slider ganz nach rechts auch auf "keine" stellen kann. Eine Begrenzung nach Energiemenge ist aber im PV-Modus nicht möglich.

Wäre es nicht sinnvoll im Sinne einer logischen Bedienung die Einstellung für die Lademenge über die verschiedenen Lademodi konsistent zu gestalten und die Auswahlmöglichkeit mit den drei Buttons auch im PV-Modus anzubieten?

3.) Eine Kleinigkeit die mich immer wieder stört: Der Ladevorgang an sich wird im Web-Interface immer wieder anders bezeichnet: Mal "Das Laden ...", mal "Der Ladevorgang ..." und - leider recht häufig (da drehen sich mir immer die Zehennägel auf) - "Die Ladung ...". Kann man da vielleicht in Zukunft eine einheitliche Ausdrucksweise einführen - wenn's geht vielleicht nicht "Die Ladung ..."?

4.) Kommt irgendwann auch mal wieder ein Passwortschutz für die Einstellungen? (openWB wird hier über das Web-Interface auf dem Handy auch von Personen bedient, denen ich eigentlich nicht unbedingt vollen Zugriff auf alle Einstellungen ermöglichen möchte, zumal dort auch sensible Daten wie bspw. die Zugangsdaten zu meinem MyBMW-Account im Klartext sichtbar sind.)

Viele Grüße,
heidanei
Gesperrt